iSpirometry App

Mobile App (iOS and Android), for real time spirometry test, directly on your Smartphone/Tablet via Bluetooth Smart 4.0 Lung function reduces much before the symptoms occur, preventing patients from becoming aware of their pathology. Worldwide, 300 million people suffer from asthma and over 200 million people have COPD. Prevention is essential. The App connects with Spirobank Smart, the simplest device for cost-effective spirometry. A Low-cost spirometer ideal for remote monitoring of respiratory illness (Clinical Trials and Population Screening), and self-management of Asthma, COPD, Lung Transplants care, Cystic Fibrosis. Software Development Kit for iOS and Android to connect Spirobank Smart directly with your own mobile App.
Main and distintive features

All the features

  • Predicted Sets and Predicted Values

    Suitable for all ages from 5 to 93 years and multi-ethnic groups (GLI predicted sets)

  • Share Medical Report

    Share results in PDF with anyone at anytime via email/whatsapp/cloud/drive bluetooth/airdrop

  • Print Medical Report

    Direct print via Bluetooth External Printer

  • E-DIARY

    Add symptoms and notes to personalize test results

  • Always included

    Unlimited Online Free Updates

  • Real Time Test

    Spirometry: FVC Parameters: PEF, FEV1, FVC, ,FEV1/FVC ratio, FEF25/75, FEV6

  • Spirometry Guidelines

    Acceptabilty Messages, Test interpretation and Quality Control Grade according to the latest Spirometry Standards

  • Pediatric Incentive

    Real time animation on Tablet/Smartphone, to improve personal compliance during the test

Want to dowload the software?

To download the software, the latest updated firmware version and manual for registered device, log in your MyMIR account.

Languages available

iOS: Czech; English; Spanish; German; Dutch; Italian; French; Polish; Portuguese; Portuguese Brazil; Russian; Turkish; Chinese Android: English, Czech, Danish, German, , Greek, Spanish, Finnish, French, Croatian, Italian, Japanese, Dutch, Polish, Portuguese, Portuguese Brazil, Russian, Swedish, Turkish, Chinese

System Requirements

Android 4.4 or higher iPhone 4s or higher iPod 5th gen or higher iPAD 3rd gen. or higher
Suitable for different products

Compatible hardware

Contact us

Ask for information or support

If you need more information about the software or you need some help, fill the form.

Scroll to top